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Lab 1-1: Platform Building

Objectives

After completing this lab, you will be able to:

· Create a new Board Support Package from an existing BSP 

· Create a new OS design from a template

· Add components from the catalog to customize your OS design

· Configure and build a run-time image

Prerequisites 
Before working on this lab, you must have:

· Familiarity with the following terms as defined in the Windows CE 5.0 on-line documentation:

· Target Hardware

· Board Support Package

· OS Design

· Design Template

· Component

· Catalog and Catalog Item

· Platform

· Configuration

· Run-time Image

Estimated time to complete this lab: 45 minutes

Lab Setup
To complete this lab, you must have:

· A development workstation running Windows XP or Windows 2000

· Platform Builder 5.0 installed

Exercise 1 
Creating a Board Support Package Clone 
A board support package (BSP) is the common name for all of the hardware specific code required to load and run the operating system. It typically includes:

· A boot loader

· Hardware specific operating system code

· Unique device drivers

In this exercise you will use the Platform Builder ‘BSP Wizard’ tool to create a copy of an existing board support package. The wizard copies the required files, and creates entries in the Platform Builder catalog for your new BSP.

In subsequent exercises, you will modify files in this copy; preserving the original BSP for reference and allowing recover from any undesirable changes. This follows ‘best practices’ guidelines, preserving the original source code as provided in the Microsoft Platform builder distribution. This step will allow you to freely modify the platform specific source code, without risk of needing to re-install Platform Builder to recover functionality in the event of a coding error.

· To create a BSP clone

1. On the development workstation, launch the Platform Builder application.

2. On the Platform menu, click BSP Wizard.
3. Click Clone an existing BSP.
4. From the available BSPs, select Emulator. Click Next.
Note

If you are working with a hardware reference platform, select the BSP corresponding to your specific hardware.

5. In the File name for .cec file box, type MyBSP. Accept the default value for Directory for .cec file and click Next.

Note

The name of your BSP’s .cec file must be unique, or the Next button will not be enabled.

6. In the Catalog Name box, type MyBSP. 

7. In the Vendor box type GeneriCo.

8. Enter anything you want into the Description box. Click Next.

9. In the Platform Directory box, type MyBSP. The CPU selections should already be correctly set for your BSP. If you are creating an Emulator BSP only x86 should be selected. Click Next.

10. On the Customization pane, click Next.

11. Congratulations, you have successfully completed the wizard. Click Finish.
The BSP Wizard will now copy the required files and update the catalog.

· Locate the new BSP in the Catalog 
12. On the View menu, click Catalog or type Alt + Shift + C to view the catalog window in Platform Builder. 

13. Right-click on the Catalog Window, and click Find.
14. In the Find What box type MyBSP and click Find Next.
The catalog item: Third Party->BSPs->MyBSP should be selected as shown below. The description will be whatever you entered for step 8 above.
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· Locate and examine the new BSP files

15. On the File menu, click Open.
16. In the Files of type box, select All files (*.*).

17. Navigate to the WINCE500\PLATFORM folder, and click MyBSP.
This is the platform root folder for your new BSP. This folder should contain three files: dirs, MyBSP.BAT and sources.cmn. It should also contain three subfolders: CESYSGEN, FILES and SRC.

Note

The BSP wizard copies all files from the parent directory. The contents of your folder may differ if you started with a different BSP, or if the emulator platform has been built previously.

18. Double click on MyBSP.BAT. This will open the file in the Platform Builder editor.

Note that other than comments, the file consists entirely of statements which set or clear environment variables. Platform Builder calls this file during the build process. The environment variable values control the details of features included in the run-time image.

19. On the File menu, click Close. Do not save any modifications you may have made to MyBSP.BAT.

20. Navigate to the WINCE500\PUBLIC\COMMON\OAK\CATALOG\CEC folder, and locate the catalog item file for your BSP, which is named MyBSP.CEC. This is an ordinary text file, and you could open it in the Platform Builder editor by clicking on it. However, the structure of catalog item files is sensitive, and modifying the file with an ordinary text editor is not recommended.

Exercise 2
Creating and Building an Operating System Design

In this exercise you will create an OS design for the BSP from the prior exercise. You will then customize that design by adding components from the catalog, and build the result. 

This OS design will be used in other exercises and labs today, and will be a suitable platform for running a variety of Windows CE applications.

You will learn how to:

· Create an OS Design from a standard design template

· Navigate the views of the workspace

· Identify the catalog features included in the design

· Extend the standard design by adding catalog items

· Set up the build configuration for your run-time image 

· Build a run-time image

· Create an OS design from a Design Template

1. On the File menu, click New Platform to launch the New Platform Wizard, and then click Next. (Note that “New Platform” would be better titled “New OS Design” as per the new 5.0 terminology.)
2. In the Name box, type MyOSDesign as the name of your OS Design workspace. Accept the default path value by clicking Next.
3. From the list of available BSPs, click MyBSP:X86, and then click Next.
4. From the list of available design templates, select Internet Appliance and then click Next.
5. Review the Applications & Media defaults and click Next to accept these settings.

6. Review the Networking and Communications defaults and click Next to accept these settings.

7. Click Finish to complete the New Platform Wizard.

Platform Builder will now generate the files for your new OS design. This takes a few seconds. Platform Builder displays the progress of these steps in the status bar, located on the lower left-hand corner of the Platform Builder window.

On completion, Platform Builder will display the workspace window. This pane defaults to being docked on the left side of the Platform Builder display, and features three views of the workspace, selected by tabs on the bottom of the pane. Let’s take a moment and examine the workspace.

8. In the workspace pane, click on the OSDesignView tab. This view closely resembles the Platform Builder catalog, with a significant difference: only those catalog items included in this OS design are visible in the workspace.

Expand the workspace catalog display in the OS Design View by clicking on MyOSDesign Catalog Items and Internet Appliance (Windows CE devices) so that the list of folders underneath Internet Appliance (Windows CE Devices) is visible. Compare this list to the entries in the catalog under Core OS/ Windows CE Devices. While similar, the list in the workspace is shorter, and the order of items is not the same as in the catalog.

9. In the workspace pane, click on the ParameterView tab. Expand the tree to reveal all the branches and files. These files specify attributes of the run-time image, including registry settings, the attributes of files stored in the image, and other parameters.

Note

Parameters in Common Files are applied to all run-time images built with your copy of Platform Builder, and in general should never be modified. Parameters in Hardware Specific Files apply to all images that use MyBSP. Parameters in Project Specific Files apply only to this particular OS design.

10. In the workspace pane, click on the FileView tab. Expand the tree so that the folders under Platform are visible. right-click on MyBSP and then click Explore.

Note

Platform Builder calls WINCE.BAT prior to opening the Windows Explorer from the workspace pane. This batch file may create files. Specifically, MyOSDesign.bif may be created in MyBSP folder.

WINCE.BAT is an important element of the Platform Builder image building process. Details of the actions of this file will be explored in a later exercise.

· Adding components from the Platform Builder catalog 

In this section, you will add components to help analyze network connectivity, and to support deployment of managed code applications.

11. On the View menu, click Catalog or type Alt + Shift + C to view the catalog window in Platform Builder.

12. Expand the tree by clicking on Catalog ► Core OS ► Windows CE Devices ► Applications and Services Development ► .Net Compact Framework. Right click on Smart Device Authentication Utility and then click Add to OS Design, as shown below. Platform Builder will add this component to the design, along with any additional components required.
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13. Expand the Applications – End User catalog folder, right click on CAB File Installer/Uninstaller and then click Add to OS Design.
14. Right-click on the catalog window, and then click Find.
15. In the Find what box, type ipconfig and then click Find next. This should expand the catalog tree and select the Network Utilities catalog item.

16. Right-click on Network Utilities and then click Add to OS Design. 

17. In the workspace pane, click on the OSDesignView tab. Verify that the following catalog items are included in your design by navigating the tree of included catalog items:

a. Cab File Installer/Uninstaller

b. Smart Device Authentication Utility

c. Network Utilities

Note

The order of the folders in the OS Design view of MyOSDesign Catalog items differs from that in the Platform Builder catalog.

· Set up the build configuration for your run-time image

Platform builder creates two configurations of your OS design:

· A Debug configuration

· A Release configuration

Both configurations support features for debugging application and operating system code. The debug configuration adds rich and flexible trace messages to most of the modules in the run-time image, including operating system components and drivers.

18. On the Platform Builder Build OS menu, click Set Active Configuration.

19. In the Configurations listbox, select MyBSP:x86_Debug and then click OK.
20. On the Platform menu, click Settings….
21. In the Configuration list, check that MyBSP:x86_Debug is selected. Click on the Build Options tab, and verify the following are selected:

· Enable CE target Control Support (SYSGEN_SHELL=1)

· Enable Eboot space in memory (IMGEBOOT=1)

· Enable Full Kernel Mode (no  IMAGENOTALLKMODE=1)

· Enable KITL (no IMGNOKITL=1)
(Leave other items selected if already selected.)
22. Click OK to close the Platform Settings dialog.

23. On the Platform Builder main menu select Build OS and make sure Copy Files to Release Directory After Build and Make Run-time Image After Build are selected.

24. On Platform Builder main menu select Build OS | Sysgen to start building the Run-Time Image.

Note

This build will take several minutes to complete. You can monitor the build progress on the Build tab of the Platform Builder output window, but this is a good time to stretch your legs or browse through the excellent Windows CE on-line documentation. On the Help menu, click Contents to launch the documentation explorer.

The build process first performs a series of sysgen operations to create executable binary files from OS component libraries. Next, it compiles and links the BSP files. If no errors have occurred, these executable and other files are copied to the release directory, then loaded into the run-time image.  On completion, the following will be displayed in the Build output window:

BLDDEMO: MyOSDesign build complete.

MyOSDesign - 0 error(s), 3 warning(s)

Some warnings, such as the 3 reported at this point in the build are a normal and expected part of the process; others indicate a more serious problem in the platform software or configuration.

Note

The Build OS | Build and Sysgen command recompiles the source code for a number of standard Windows CE components. These components are distributed in compiled form as part of the Platform Builder installation. Rebuilding these components is not required unless you have modified the Microsoft source code in the PUBLIC or PRIVATE trees, which you should never do anyway. It is recommended to use the customization options of Platform Builder and remove the menu so you don’t use it accidentally. 
Exercise 3
Connecting, Downloading, and Using a Run-time Image

In this exercise you will learn how to:

· Configure the connection between Platform Builder and a target device

· Download and boot a run-time image

· Run programs on the device

· Check the device network configuration parameters

· Reset the device from Platform Builder

· To create a new connection to an emulated target device

1. On the Platform Builder Target menu, click Connectivity Options.

2. Click Add Device. In the New target device name box, type MyBSP Emulator and then click Add.
3. Click Kernel Services Map. Make sure the Target Device list has MyBSP Emulator selected. In the Download list select Emulator. Also, in the Transport list select Emulator. The Debugger list should have selected KdStub. Click Apply.

4. Click the Settings button next to the Download list to bring up the Emulator Download Settings dialog. 

5. Make sure Display radio button is selected, and that Width is set to 800, Height to 600, and Color depth is set to 16.

6. Make sure Memory is set to 64 MB.

7. In the Ethernet Support list, select Virtual Switch – <adapter name> where <adapter name> is the name of the adaptor on your development workstation which will be shared by the emulator. Click OK.

[image: image3.png]Communication

Ethernet support;

[rtual Switch — Broadcom 440< 10... <]
Disabled

Serialport 1

INAT (Otgaing orly)

(ool debug )[Rt sccany




Note

If the development workstation has more than one Ethernet adaptor, each adaptor will have a separate Virtual Switch entry in the Ethernet Support list. Be sure select the entry corresponding to a wired Ethernet adaptor connected to your network.

8. On the Target Device Connectivity Options dialog, click Core Service Settings. Make sure the Target Device list still selects MyBSP Emulator. The Download Image option should be set to Always. Enable KITL on device boot, Clear memory on soft reset, and Enable access to desktop files should all be selected.

9. Click Apply. The status message on the bottom line of the Target Device Connectivity Options dialog with display “Target device core service settings are updated” to indicate all changed have been accepted, as shown below.
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10. Click Close to complete the options setting dialog.
· To download and boot run-time image on the emulated target device

11. On the Target menu, click on Attach Device. This will start the Emulator for Windows CE and download the run-time image to the device. After a 15 seconds or so, the emulator should complete initialization, and a Windows CE desktop should be present.

Note

If Platform Builder fails to connect to the emulator in this step, check the Target Connectivity Options to make sure that both Download and Transport are set to Emulator.
12. If the Download Runtime Image dialog remains open after the download completes, click Close this dialog box when download completes and then click Close.

Note

During target device initialization and operation, diagnostic messages are displayed on the Debug tab of the Platform Builder output window.  Some of these messages may sound serious, for example “OEMIoControl: Unsupported Code …” but do not indicate an error condition. Usually a serious error will be followed by additional failures or exceptions.
· To run a program on the emulated target device

There are many ways to start a program on the target device.

13. On the Windows CE target device desktop, double-click on the Internet Explorer icon. If your network connection has Internet access, the browser will open http://www.msn.com home page.

Note

A proxy server may be required to browse the Internet.
14. Click on the Windows CE target device Start menu and then select Settings | Control Panel to open the control panel on the target device.

15. On the Platform Builder Target menu, click on Run Programs. In the Available Programs list, select ceplayer.exe and then click on Run to launch the Windows Media Player on the target device.
16. At the Platform Builder target control window Windows CE> command prompt, type s cmd followed by the ENTER key, to launch a command interpreter window on the target hardware, as shown below:
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Note

The target control window is only visible when an image has been downloaded and the target is running. If you inadvertently close this window, reopen it by clicking Target | CE Target Control on the Platform Builder menu.

17. On the Windows CE target device command window, type ipconfig /all followed by the ENTER key for a detailed report of the Windows IP configuration.

· To reset the target device from Platform Builder

18. On the Target menu, click on Reset Device. Dismiss the warning that “This command will reset the device” by clicking on Don’t show this message again and then clicking on OK.
After the device resets, the run-time image will be automatically downloaded, in accordance with the connection configuration settings. The target device display may not change until the run-time image initialization completes.

Note

Most, but not all Windows CE hardware platforms support the Platform Builder reset command.
Note

If you close the emulator, the device is not automatically detached from Platform Builder. From the Platform Builder Target menu, click Detatch Device, and then Attach Device to reestablish the connection to the emulator if needed.

Disconnect and Close Platform Builder

19. On the Target menu, select Detach Device. Check the “Don’t show the message again”box on the message that appears next and then select Yes.
20. Close the Emulation Window.

21. Close Platform Builder.







